CCNA Home LAB

 

During my study for my VCP5-DCV certification I found that having a home lab was a huge asset in terms of being able to get a better understanding of the subject matter. Now that I am working towards my CCNA Routing and Switch I feel this will be the case once again.

My goal is use the home lab to work on labs as per the study guides I am using and also to have something productive to work on when I don’t feel like reading through a study guide. Let’s face it all study guides can get a bit dry.

The home lab PC was originally spec’d up for running a nested ESXi environment and is overkill for what I will be doing for my CCNA.

  • i5-4690
  • 32 GB Ram
  • 512 GB SSD drive
  • Windows 8.1

To the setup.

I will be using GNS3 and VirtualBox to setup the lab environment, which is a pretty standard setup for people undertaking the CCNA. VirtualBox is a requirement to be able to run IOU devices as well as being able to connect VMs into the network.

I have started my configuration a bit out of order from the study guide I am using so I can test connectivity. The only changes to the router from a blank config are the setup of DHCP server, IP configuration of FastEthernet 0/0 and 0/1 as well has no shutdown.

Starting Topology

The starting topology is very simple, a router R1 and Layer2 device through IOU and a Debian VM.

Network topology

The DHCP config


no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1 192.168.10.20
!
ip dhcp pool Internal
network 192.168.10.0 255.255.255.0
dns-server 4.4.4.4
default-router 192.168.10.1

Interface Setup

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!

interface FastEthernet0/1
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!

Getting communication between the Debian VM and the devices took a bit of effort, but wasn’t too bad.

Adding a VM to GNS3 is a very simple process. Go to Edit > Preferences > VirtualBox VMs > New. Then just select the VM you want to add and your done.

To get the VM to communicate with the devices go to Edit > Preferences > VirtualBox VMs > Edit > Network and tick Allow GNS3 to use any configured VirtualBox Adapter

debian network GNS3

When I powered on the project the network settings for the VM in VirtualBox had been updated.

debian network vb

 

Everything booted fine and communication tested well.

DHCP setup confirmed

DHCP setup confirmed

Ping VM to FastEthernet 0/0

Ping VM to FastEthernet 0/0

Ping VM to FastEthernet 0/1

Ping VM to FastEthernet 0/1

Communication from VM to router has been confirmed and that the VM can communicate with FastEthernet 0/1 which is on another network.

 

This is my starting configuration for my CCNA lab which I’m sure will get plenty of use as well has get broken many times during the course of my study.

 

Study material:

Sybex CCNA Routing and Switching

Chris Bryant’s CCNA Study Guide, Volume 1

Chris Bryant’s CCNA Study Guide, Volume 2

CBTNuggets

 

Leave a Reply

Your email address will not be published. Required fields are marked *